:orphan: .. index:: pair: enum; dhcp_option_type .. _doxid-group__tapi__tad__dhcp_1ga2f131f9263eeed20897eff4a0985192e: enum dhcp_option_type ===================== Overview ~~~~~~~~ Type of DHCP Options :ref:`More...` .. ref-code-block:: cpp :class: doxyrest-overview-code-block #include enum dhcp_option_type { :ref:`DHCP_OPT_INVALID` = -1, :ref:`DHCP_OPT_SUBNET` = 1, :ref:`DHCP_OPT_ROUTER` = 3, :ref:`DHCP_OPT_NAME_SERVERS` = 6, :ref:`DHCP_OPT_HOSTNAME` = 12, :ref:`DHCP_OPT_DOM_NAME` = 15, :ref:`DHCP_OPT_ROUTER_DISCOVER` = 31, :ref:`DHCP_OPT_STATIC_ROUTE` = 33, :ref:`DHCP_OPT_VENDOR_SPECIFIC` = 43, :ref:`DHCP_OPT_NETBIOS_NAME_SERVER` = 44, :ref:`DHCP_OPT_NETBIOS_NODE_TYPE` = 46, :ref:`DHCP_OPT_NETBIOS_SCOPE` = 47, :ref:`DHCP_OPT_REQUESTED_IP` = 50, :ref:`DHCP_OPT_LEASE` = 51, :ref:`DHCP_OPT_MESSAGE_TYPE` = 53, :ref:`DHCP_OPT_SERVER_ID` = 54, :ref:`DHCP_OPT_PARAM_REQ_LIST` = 55, :ref:`DHCP_OPT_VENDOR_CLASS` = 60, :ref:`DHCP_OPT_CLIENT_ID` = 61, :ref:`DHCP_OPT_USER_CLASS` = 77, :ref:`DHCP_OPT_AUTO_CONFIG` = 116, :ref:`DHCP_OPT_SIP_SERVERS` = 120, :ref:`DHCP_OPT_CLASSLESS_STATIC_ROUTE` = 121, :ref:`DHCP_OPT_VI_VSI` = 125, :ref:`DHCP_OPT_PVID` = 150, :ref:`DHCP_OPT_6RD` = 212, :ref:`DHCP_OPT_CLASSLESS_STATIC_ROUTES` = 249, :ref:`DHCP_OPT_END` = 255, }; .. _details-group__tapi__tad__dhcp_1ga2f131f9263eeed20897eff4a0985192e: Detailed Documentation ~~~~~~~~~~~~~~~~~~~~~~ Type of DHCP Options Enum Values ----------- .. index:: pair: enumvalue; DHCP_OPT_INVALID .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ead2deb5aa1c42f6ed40cdc2d322569206: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_INVALID Invalid option .. index:: pair: enumvalue; DHCP_OPT_SUBNET .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192eaae22bf8228511018e70435d5f46747a6: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_SUBNET Subnet mask .. index:: pair: enumvalue; DHCP_OPT_ROUTER .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192eacc8722fc2b5bedd5c280efd0b0c6c84c: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_ROUTER Router .. index:: pair: enumvalue; DHCP_OPT_NAME_SERVERS .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ea87d850f6183bb99c54c6bd62419c2362: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_NAME_SERVERS Domain name servers .. index:: pair: enumvalue; DHCP_OPT_HOSTNAME .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ea1bd0d57ae652cb6a00c684b43075bc66: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_HOSTNAME Name of the host .. index:: pair: enumvalue; DHCP_OPT_DOM_NAME .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ea55c08e39fe90d0d5abc5865d8d10cafa: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_DOM_NAME Domain Name .. index:: pair: enumvalue; DHCP_OPT_ROUTER_DISCOVER .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ea0f239994c5a16d50e72e3d40e90e48f5: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_ROUTER_DISCOVER Router Discover .. index:: pair: enumvalue; DHCP_OPT_STATIC_ROUTE .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ea3c55fc65221e9ff50bf500a271fee964: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_STATIC_ROUTE Static Route .. index:: pair: enumvalue; DHCP_OPT_VENDOR_SPECIFIC .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192eae0628b8a26a48c0d657199284e04e92b: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_VENDOR_SPECIFIC Vendor-specific .. index:: pair: enumvalue; DHCP_OPT_NETBIOS_NAME_SERVER .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ea7c37e922b1cd45153d40184827ce1cf2: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_NETBIOS_NAME_SERVER NETBIOS name server .. index:: pair: enumvalue; DHCP_OPT_NETBIOS_NODE_TYPE .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ea570ae18b8fde847751df706a091385e9: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_NETBIOS_NODE_TYPE NETBIOS node type .. index:: pair: enumvalue; DHCP_OPT_NETBIOS_SCOPE .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ea7663b43d9dc3accb68921d60d16d4f66: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_NETBIOS_SCOPE NETBIOS scope .. index:: pair: enumvalue; DHCP_OPT_REQUESTED_IP .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192eaa371647c5c23bb9a1f1ce8ff1b6657ad: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_REQUESTED_IP Requested IP .. index:: pair: enumvalue; DHCP_OPT_LEASE .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192eaeaf13d4a9aaeb3fb8aaaea784a0a028c: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_LEASE Lease time .. index:: pair: enumvalue; DHCP_OPT_MESSAGE_TYPE .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ea02f3fb7068c3e4b5628318a43aa5cef1: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_MESSAGE_TYPE DHCP Message Type .. index:: pair: enumvalue; DHCP_OPT_SERVER_ID .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ea9c055960c85c6fcfb4d9c8f5f2891b1a: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_SERVER_ID Server Identifier .. index:: pair: enumvalue; DHCP_OPT_PARAM_REQ_LIST .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192eae9e7f9eecc6065d1e49b440cd102ef49: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_PARAM_REQ_LIST Request list .. index:: pair: enumvalue; DHCP_OPT_VENDOR_CLASS .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ea805267c452fd22663e44f32c2ce044d9: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_VENDOR_CLASS Vendor class .. index:: pair: enumvalue; DHCP_OPT_CLIENT_ID .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ea730a1ca1ca838e02e06e58c39ef4050b: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_CLIENT_ID Client ID .. index:: pair: enumvalue; DHCP_OPT_USER_CLASS .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ead0fb528782a938a7b6fe9fa1465abca8: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_USER_CLASS User class .. index:: pair: enumvalue; DHCP_OPT_AUTO_CONFIG .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192eabfb73f1d047593393971836619c8a1c1: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_AUTO_CONFIG Auto configuration .. index:: pair: enumvalue; DHCP_OPT_SIP_SERVERS .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ea47505a001294d6c4ac85086fb8ecdbd3: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_SIP_SERVERS SIP servers (RFC 3361) .. index:: pair: enumvalue; DHCP_OPT_CLASSLESS_STATIC_ROUTE .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ea10db1de8b52121367949d3550a57ab48: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_CLASSLESS_STATIC_ROUTE Classless static route (RFC 3442) .. index:: pair: enumvalue; DHCP_OPT_VI_VSI .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ea414e7fd4f072517f2f20d68cce36939f: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_VI_VSI Vendor-Identifying Vendor-Specific Information (RFC 3925) .. index:: pair: enumvalue; DHCP_OPT_PVID .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ea349191996d2c7d75817d55320ad219b5: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_PVID Port VLAN .. index:: pair: enumvalue; DHCP_OPT_6RD .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ea808061331fdd03b43af13abf31b3d6cb: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_6RD IPv6 Rapid Deployment on IPv4 Infrastructures (6rd) .. index:: pair: enumvalue; DHCP_OPT_CLASSLESS_STATIC_ROUTES .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ea46380df75f126b6e10563deaf3949158: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_CLASSLESS_STATIC_ROUTES Classless static routes .. index:: pair: enumvalue; DHCP_OPT_END .. _doxid-group__tapi__tad__dhcp_1gga2f131f9263eeed20897eff4a0985192ea16551ffc10c9db2a717bb1514aaddf01: .. ref-code-block:: cpp :class: doxyrest-title-code-block DHCP_OPT_END End option